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ADDING PAGES

Add A Page

Every time your site is visited, the first page to open would always be the Welcome Page, or Splash 
Screen in other terms. So, it would be a good idea to begin your site with the Splash Screen.

If you chose to follow this advice, select Splash Screen in the box provided. Click Next to continue 
with the design of the page.

Splash Screen

Splash Screen is the home page that welcomes visitors and contains links to all other pages.



To configure Splash Screen, fill out the Splash Page form:

●     Splash Theme:
the main parameter that determines the look of your home page. E-Family Sites offers several 
Splash Screen templates (themes). Choose one - you can change it any time in the future. The 
current version of E-Family Sites does not provide immediate preview, so it is recommended 
to configure it after you configure all other parameters (see instructions below in this section). 

●     Logo image:
Splash Screen templates are designed to include a welcome image. You can select a picture 
that is stored on your hard disk or has been already uploaded to your gallery. To include a 
picture click the "Select Image" button and follow the on-screen instructions. 

●     Page Title:
This is the text that will show up on the welcome page in big letters. This would usually be 
either the name of your site or a welcome sentence. 

●     Lock Splash Settings:
By default, Splash Screen is not affected by the global color settings for your site. Here, you 
can allow E-Family Sites to modify Splash Screen properties by checking "No" radio button 
in the Lock Splash Settings field. 

As you finish, click the Next button to save your settings. The View tab (see Tabs for details) will 
open for preview. How do you like your welcome page? 

Okay, now let us look back at the themes. Click the Edit tab and select a different theme, then go to 
the bottom of the page and click Next. Try other themes to choose the best one.

Important: your site will be published only after you press the Publish link on the menu bar, in the 
upper left-hand corner of the screen.

About

The About page is commonly used to provide the following blocks of information:

●     The purpose of the site; 
●     The owner of the site (a person or a company); 
●     Any other relevant data. 

Enter your text into the boxes provided. Paragraph headings are optional.

E-Family Sites allows you to include a picture into the About page. This could be a picture of 
yourself (for a personal site), your working team (for a company), a logo or any other relevant image. 
To include a picture, click the "Select Image" button. Then follow the on-screen instructions.

After you add an image, its thumb view will become available in the form, as well as a Remove 
Image button. Click it to remove selected image from the About page.



After you key in or copy/paste the data you want to show on your About page, click the Next button 
to save your settings, and you will be brought to the View tab (see Tabs for details).

Resume

This is the central page for those who seek employment via the Internet. It provides an easy-to-use 
wizard that allows you to effectively manipulate the data you would like to include into your resume.

As the first step, you will see seven boxes with suggested section headings, each with an Add button 
on its right. Click the Add button to enter data into the relevant section. A new form will appear. Fill 
it out and press Next to return to the main Resume page. The information you entered will show in 
the box; also, Edit and Delete buttons will be added. Click Edit to change contents of the box, and 
Delete to clear the contents. Follow this instruction for every section you want to include into your 
resume.
Note: In the Experience section form, you will have an in-built form for job duties. The instructions 
are exactly the same as above.
Attention: Make sure you don’t add empty forms! They will be included into your resume, too.

You can preview your resume at any moment by clicking the View tab (see more on Tabs). Your all 
changes will NOT be lost. At the end, however, don’t forget to confirm the changes by pressing the 
Next button!

Now that you see your resume in a complete form, you may see how to make it more visually 
appealing. Click Settings tab to change color, font or style (see more on Tabs).

When you have your web page in front of your eyes you may decide to change the order of some 
paragraphs. It's simple and fast. 

●     Click the Order Elements link to re-order your paragraphs. A new window will appear.
●     In the box, click to highlight the name of the item you want to move; 
●     Use the UP and DOWN buttons to move the selected item up or down the list; 
●     Click the Next button to save changes and return to the Resume Edit page.

Links

Part of expressing yourself through a web page is including links to your favorite web sites. The links 
you choose to include on your page can communicate your interests and hobbies. If your goal is a 
company site, think of resources related to your field or industry. A carefully designed collection of 
related links can make your site a good launching place and will help you promote your site - and 
business. 

●     Header Text:
The text that shows at the top of the Links page as a header. It usually details the page title or 
serves as a header to the introductory paragraph.



●     Paragraph:
The introductory paragraph to the Links page.

●     Columns of Links to Display:
Links can be organized into multiple columns.

●     Add button is used to create a new Link category. 

To keep your links organized, E-Family Sites places new entries into categories. To add a category or 
links to your Links page: 

●     Click the Add button. This will call another form.
●     Enter the name of the category; 
●     Click Add (Add Link); 
●     Fill in the fields (Site title and Site URL), than click Next to continue; 
●     To add link - click Add; 
●     To make some changes - click Edit; 
●     To delete link - click Remove; 
●     Click Next when finished.

To edit an existing category:

●     Click Edit button; 
●     Edit the name of the category; 
●     Click Add to include a new link; 
●     Click Next to save changes.

To delete an existing category, click Delete button. Warning: All links contained in this category 
will be permanently deleted!

Custom Table Page

Custom page table is a page with any data organized in a table format. To create a table, fill out the 
form:

●     Border:
enter a numerical value representing the width of grids in pixels. To hide grids, leave the field 
empty or enter 0.

●     Width:
Table width can be indicated in pixels or in percent of the page width. To enter width in 
percent, put the "%" symbol after the numerical value.

●     Cell Padding:
distance from text to border, both vertical and horizontal.

●     Align:
aligns the table on the page.

●     Resize:
Enter the number of rows and columns for your table and press Resize button before clicking 
Next.



Note: If you input an incompatible set of parameters, E-Family Sites will optimize conflicts in these 
data.

Site Map

This page shows the structure of your site. It is generated automatically and does not allow editing. 
However, you can configure its settings, just like you it for other pages.

Photo Album

For a personal site a photo gallery may become the central element with photos of yourself, your 
friends, your family, your art works, postcards, etc. For a production or service company, it may be 
used to advertise your products or services.

To create a photo album, fill out the fields in the form as the first step: 

●     Title:
the text that shows at the top of the menu bar.

●     Select numbers of pictures per page:
Mind the size of your pictures. It is recommended that all your pictures fit one screen. Follow 
the simple rule: the bigger the image size, the fewer pictures per page. 

●     Enter the number of columns:
Change this parameter depending on whether your images have a horizontal or a vertical 
layout.

In the next step, add images to the Photo Album: 

●     Click Add. A new form will appear;
●     Fill in the picture title and the date in any format;
●     Click the Select Image button. You will be brought to the Upload Images page. Follow on-

screen instructions to add a new image.
●     Add details. This may be a description of the place or names of people in the picture.
●     Click the Next button to proceed. 

To change or remove images use the buttons under the Image. 

To add more images to your album click Add and repeat the steps above.

Your Own HTML

This tool contains a simple HTML editor allowing you to create web pages based on your own 
HTML script. However, it is recommended that you create your files in specialized html editors. To 
upload a file from your hard drive, click the Upload File button at the bottom of the page.



When uploading your own HTML page, try to avoid non-Latin characters, spaces, underlines, 
commas, dots, hyphens, etc. It is recommended that your file name only includes letters of Latin 
alphabet and numbers. 

Fun Page (Humor)

Fun page template helps you organize your fun topics. To add an item, click the Add button for the 
appropriate category and fill out the form that appears.

To add pictures to your Fun Page: 

●     Click Add in the in the Add Funny Pictures box. A new form will appear.
●     Enter the name of the picture.
●     Click the Select Image button. You will be brought to the Upload Images page. Follow on-

screen instructions to add the new image. 
●     Add text. This may be any comment to the new image. 
●     Click the Next button to proceed. 
●     Click the View tab to see the page preview.
●     Click the Edit tab to continue editing the page.

To change or remove images or texts, use the Edit and Delete buttons on the left of the picture or 
text. 

To add more images to your album click Add and repeat the steps above.

To change the order of the jokes, images or stories, click the Order Items button in the appropriate 
form. A new form will appear. Follow on-screen instructions to change the order of the items in the 
topic.

Survey Form

This template will help you develop a custom online questionnaire. Use it to research public opinion 
or to get feedback from your customers.

To generate a questionnaire, fill out the form:

Page Title:
Page title is the text that will show at the top of the menu bar. For convenience, it duplicates the same 
field in the Settings tab. In this field, you can change E-Family Sites default name from "Survey" to, 
say, "Questionnaire" or "Feedback".

Button Text:
This is the text that will show up on the global site menu among other page names. It may be the 
same as the Page Title, or you can give it a different name.



E-mail To:
Here, enter the address where you want the survey results e-mailed. It can be the Webmaster’s (i.e. 
your) address as well as any other address you specify.

Questions:
To add a question, click the Add button on the right. A new form appears. Checking "Yes" in the Is 
The Answer Required field marks the survey question with a red asterisk. The survey will not be 
accepted from a visitor if one or more asterisked questions remain unanswered. The Question Type 
determines the format of the suggested answer. Carefully fill out this form and click the Next button 
to proceed. 

On Successful Submission of the Form:
Here, enter the text you want the visitor to see after the form has been accepted.

On Error Submission of the Form:
Here, enter the text you want the visitor to see after the form has been rejected or an error occurred.

Click the Next button to generate the questionnaire.

Generic Page

Generic Page template has been designed to enable fast and simple creation of custom pages that do 
not fall into any other categories. You can choose how to lay out your images and text depending on 
your tastes, needs and circumstances.

●     Marquee:
This is a scrolling area of text. To add a marquee, click Add link. A marquee form will 
appear. Enter the text you want to scroll, width and height in pixels, scrolling speed, 
horizontal page alignment and vertical screen position, and the font style. Press the Submit 
button to proceed.

●     Number of Columns:
Multiple columns for the whole page can be combined with individual paragraph design.

●     Choose Title For this Page:
Page title is the text that will show at the top of the menu bar. For convenience, it repeats the 
same field in the Settings tab.

●     Choose Link Text: This text will show on other pages as a hyperlink to this page.
●     Edit Paragraphs: You can add, delete and edit only individual paragraphs, including 

headers, body texts, images and image titles. All elements are optional!

To add or edit paragraphs:

●     Click Add or Edit. A new form will appear.
●     Select paragraph layout by sliding you mouse over the buttons at the bottom of the page and 

clicking one of them.
●     Enter Paragraph Header; 



●     Click the Select Image button to add a picture; 
●     Enter Paragraph Text;
●     Click Next to preview.

Family Tree Page

Your family page includes two major blocks of information, one about the whole family, and the 
other about its individual representatives.

To provide general family information enter the following fields:

●     Title:
It could be as generic as "My Family" or as specific as "The Simpsons Family Tree".

●     Header Text:
give some introductory information about your family.

●     Family Portrait:
Click the Select Image button to add a picture from your computer.

To provide information about individual family representatives:

●     click the Add button. A Family Member form will appear. 
●     Fill out the form. (Note: The date format does not matter). It is recommended to start your 

Family Tree with the ancestors.

Warning: Clicking the Delete tab will remove the whole Family Tree Page, not a family member 
page! To remove individual persons from the family tree, click Next in the Family Member form to 
return to the Family Tree form and click the Delete button on the left of the person’s name.

On the Family Tree central page you can see the general family genealogy information.

To view individual family member’s page, click this person’s name. To return to the general family 
page, click Back to Family Tree at the bottom.

Calendar

The calendar is nothing but a page listing events like birthdays, anniversaries, etc. 

●     Date:
this field is insensitive to the format of the date.

●     Headline:
what is the event about. E.g.: "Our fiftieth wedding anniversary".

●     Text:
the optional comment you may want to add. E.g.: "Not celebrating".

●     Type:
the color in which the record will appear:



❍     Usual - green;
❍     Important - blue;
❍     Alert - red.

ICQ Contact Center

If you extensively use ICQ, you will find this form of messaging the most convenient.

To add the ICQ Contact Center page, fill out the fields:

●     ICQ Number:
your active ICQ number to which the messages will be directed. You can copy it from your 
ICQ View/Change My Details window.

●     Subject:
Every message directed to you by a visitor of your site will have this subject included. A good 
name for the Subject would be something like "Sent From My Site".

●     Online Indicator Type:
Your ICQ-message page contains an online indicator that shows your current status (e.g. 
online or offline). Here, you can choose how you want it to look. To preview, click the View 
tab. To continue editing, click Edit tab.

●     Status Indicator Description:
The text that appears next to the online indicator. You can change the default text to, for 
instance, "The Webmaster is". Some indicator types include text like "My current status is:" 
For these types, keep this field blank.

Press the Next button to proceed.

Driving Directions

This is a powerful tool for visitors to get the driving directions to any address in North America that 
you specify. For a personal site, this can be your home or hangout. For a business site, show the 
location of your restaurant, store (supermarket) or a service center.

To create the page, enter the details of the destination address and press the Next button to preview.

To change data, click the Edit tab.

E-Store (Amazon.Com Web Store)

To create your online bookstore, do the following steps:

1. Sign up.



You need to sign up to become an Amazon.com associate. Click here to sign up or here to find more 
about the associate program.

2.Fill out the form

●     Associates ID:
After you subscribe with the associate program, you will be assigned an associate ID. Enter it 
into this field.

●     Create Your Sales List:
enter the names, prices, and descriptions of the books you want to sell. Then press Next to 
preview.

Mobile Pager

Configuring mobile messaging with the Web Building Tool is as simple as entering the phone or 
pager number, selecting service type and provider and clicking the Next button.

Tabs

Look at the tabs right under the toolbar menu. They supplement every page-designing tool:

Edit tab opens by default, suggesting that you should enter or change your data before viewing it. 
Forms in the Edit tab vary greatly from page to page. 

View tab allows you to view your changes. This option is always available when you work on Edit or 
Settings tab. This means that after you introduce any changes to your page data or settings, you can 
immediately view them by clicking the View tab.

Settings tab. Here you can customize all parameters for your page. For details go to Standard 
Settings Tab.

Delete tab permanently removes the page from your site.

Note: You can switch between tabs to change any data or settings any time during the page 
construction process or later.

Standard Settings Tab

Page Title

Page title is the text that will show at the top of the menu bar. In this field, you can change E-Family 
Sites default name from "Fun Page" to, say, "Laugh with us".

http://associates.amazon.com/exec/panama/associates/apply
http://www.amazon.com/exec/obidos/subst/associates/join/associates.html


Button Text

This is the text that will show up on your site’s menu among other page names. It may be the same as 
the Page Title, or you can give it a different name. For example, if your Page Title is "Fun Page", you 
may want to add some versatility by typing something like "Smile!"

File Name

Technically, your site is nothing but an organized inter-linked group of html pages (files). E-Family 
Sites enables you to assign a specific name for every page that you add to your site. It is 
recommended that your file name only includes letters of Latin alphabet and numbers. Try to avoid 
non-Latin characters, spaces, underlines, commas, dots, hyphens, etc.

Title, Text, Heading

You can select: 

●     Font - use pull-down menu; 
●     Color - click on Change color button, when the color scheme appears, click on Selected 

color; 
●     Lettering Style - simply click on letter symbol. 

After you change the settings click Next to see the result.

Rollover effect

When you move your mouse over some elements on a page, they may change their color, shape and 
other properties. This is called Rollover Effect.

Background Image

You can place the contents of your page on an image. However, try to be discreet with choosing the 
background. Avoid using photographs or bright decorations, as they may hinder text readability.

Colors

E-Family Sites allows you to change the color palette for every site's page. Their default HTML 
codes are in the boxes next to the parameter names. You don’t need to know these codes. Instead, 
click the color icon to call a Color Picker - a palette with colors available - and select the color you 
like. The "Color" section allows you to change background, text and links color. Just select the 
element you wish to modify and click on the color you like. 

Note: If you decide to change background color, ensure that the text on your page is clearly readable. 
There must be sufficient contrast between the text and the background image. A background with too 



much contrast competes with the text for reader's attention and makes it difficult to read. 

Secure

You can make your page open to general public or closed (secure). Secure sites or pages are often 
used by multinational companies to communicate closed information to its representatives 
worldwide, where e-mailing is not appropriate.

Choose Yes if you want to restrict access to the page. The frame will expand to include a drop-down 
list box where you can choose who is allowed to view the page. To create an authorized user or user 
group, go to Site Settings -> Edit Security Information (for comments see Edit Security 
Information help section).

Uploading images

Go to the directory or folder on your computer where your picture is saved, select the picture you 
want to add to your page, and click the Open button. The location of the selected file appears in the 
"Upload Image" window. Click the Upload button in the "Upload Image" window.

You can select images from: 

●     Your own computer; 
●     Gallery of images that you have uploaded before (your gallery); 
●     E-Family Sites image library (not included in some versions).

ORDER PAGES
To re-order your pages do the following: 

●     Click to highlight the name of the page that you want to move; 
●     Use the up and down buttons to move the selected item up or down the list; 
●     Click the Next button to save changes.

SITE SETTINGS

Site Settings

Click the category you need help with:

●     Website Category
●     Website Color & Style



●     Global Settings (General Contact Information)
●     Website Theme/Effects
●     Load/Save Website
●     Start Over
●     Edit Security Information

Note: When available, use the navigation buttons inside the browser window. For some pages, your 
browser's Back and Forward buttons will not work correctly. If a page fails to load, or does not 
reflect last changes, click your browser's Reload or Refresh button to update the page. 

Website category

To select the website category, scroll the list of suggested topics in the box in the right half of the 
page. Select the topic for your site and click it. Then, click the Next button. You will be brought to 
the Select Website Color and Style page.

Attention: Once you begin to create your site you may not change the website category!!! To change 
the category, you will have to start anew, which will delete ALL PREVIOUSLY SAVED SITES.

Website color & style

Choosing a correct layout is crucial for the success of your web site, as it will determine the look of 
every page. E-Family Sites is equipped with a number of pre-designed Overall Site Layouts. Go 
through the list in the upper left box by mouse-clicking each item or using cursor keys on your 
keyboard. Sample pages will be shown in the preview window on the right. Stop on the one that will 
best suit the contents of your site.

Then, select a color scheme in the lower box. It will only affect the menu bar; colors for every 
individual page are set at a later stage (see Standard Settings Tab).

You can change your layout and color scheme any time in the future without losing any information 
whatsoever, even when the construction of the site is complete. 

The checkbox allows you to apply selected layout and color scheme to all pages on your site. It 
comes checked by default. If you uncheck it, the layout and color settings will only affect the pages 
you create after applying these changes; the pages you created before will remain unchanged. 
Changing this option doesn’t affect your settings in any way, if you are only beginning to create your 
site. 

After you select the layout and color settings, click Next to move on.

Global Settings



Web readers often want or need to contact the person who created and maintains the web site. Global 
Settings form requires you to enter basic information that will help identifying the site and its author 
after it is published. 

In the Search Engine Keywords box enter the words or word combinations that distinguish your site 
from all other sites on the Internet. They will be helpful when somebody tries to find your site with a 
search engine. Think of the words that would be most characteristic of your site.

In the Search Engine Description box enter a short description of your site, like an answer to the 
question: What is it about? If an Internet user finds your site with a search engine, this description 
will show right under the site name.

You can enable visitors to perform text search on your site. This functionality takes a form of a 
textbox added to the menu bar. A visitor will type a word or a combination of words and they will be 
searched throughout all texts on your site. If you want to include a search engine into your site, click 
"yes" at the bottom of the form. Otherwise, choose "no".

At this point, you are done with general site settings. Click the Next button to configure individual 
pages.

Website theme / effects

Add themes and special effects! Make snowflakes fall down in the browser, add logos that stay put as 
the user scrolls, and tons of other cool features, all with easy point and click selection.

There are several check boxes to indicate and select the theme (javascript effects) that you can see on 
your web page. Use pull-down menu for selection. Then, click Next to preview. 

Falling Things:

●     Snow - the snowflakes will fall on your screen; 
●     Snow 1 - just the same action but another type of snowflakes; 
●     Leaves - the leaves will fall and fly on your screen; 
●     Angels - the same actions but Angels (instead of leaves) will fall on your screen.

Items. Please use pull-down menu to select the number of snowflakes (leaves). 

Theme 1. Here you can include the "Top down curtain" effect. Try not to include too many effects. 

Cursor pointer. Here you can select: 

●     Cursor text. The name of the web page will trail the cursor. 
●     Colorful tail. The colorful tail will follow the cursor.

Site logo. Specify where you want to place the Logo image. 



Logo duration. Specify how long you want the Logo to show on the page after it is loaded. 

Alt text. Enter the tooltip text - a brief message that will pop up next to the cursor when it stops over 
the Logo image. 

Load / Save website

You can save up to five different versions of your site. Make sure the names you enter reflect 
changes between versions. 

Attention: Before retrieving a previously saved website, save your work! If you don’t save your 
current project, you will lose it. E-Family Sites can work with only one site at a time. 

Warning: Starting over will delete ALL PREVIOUSLY SAVED SITES. To start a completely 
new site, you need to register as a new user.

Note: Saving your web site will not publish it. To publish your site, click the publish link at the upper 
left-hand corner on the menu panel.

Start Over 

Scrap all your pages with one click, and begin designing anew. Use this option only if you are 
completely sure. There will be no way to get back your current pages if you start over.

This option allows you to delete all your web pages with ONE click and start to design from the 
beginning. Warning: You will lose your current site as well as ALL PREVIOUSLY SAVED 
SITES. Don’t use this function if you are not strongly sure!

Edit Security Info

You can make your site open to general public or closed (secure). Secure sites are often used by 
multinational companies to communicate current information to its representatives worldwide, where 
e-mailing is not appropriate.

In this section you need to specify the users or user groups authorized to access your secure site. 
After you include them into the authorized user list, communicate to them their passwords.

To secure individual pages, go to Page Settings tab (see Page Settings help section for details).

Site Map

Here you can see and inspect all the web pages your web site consists of. 



●     to preview page content click View. You will be brought to the page’s View tab.
●     to change, add or delete info - click Edit. You will be brought to the page’s Edit tab. 
●     to delete the page click Remove. The page will be permanently deleted.
●     to change the look and feel of the page, click Settings. You will be brought to the Page 

Settings tab.
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